hamr

All posts tagged hamr

Here is a Saturday morning update report regarding my rf switch project.
Back to the good old drawing board, I guess.
Switch are switching ok, and loses are acceptable, this is fine.
However, it is picking up ambient noise. I suspect its being a shielding problem and an isolation problem between RF parts and DC parts of the relays.
To give you an idea of the rx degradation with this thing is in line compared to the narda 023.
Pointing the 144 array to a relatively cold spot, the wsjt noise floor rises about 4dB, and this is simply not acceptable. This thing is useless for weak signal work until these problems are rectified.
I have now installed a narda 023 again.
Hoping to do some EME contacts again this weekend. See you on the moon.

Morning report: Saturday 25.03.2017, still messing around with my quest for low cost high power rf-switch. I have cut and soldered a lot-lot-lot-lot-lot of coaxes since last post and….. Well, now it is looking really good, I have exchanged all the small diameter coaxes with larger ones, and there are now no heat loss I can feel with my fingers!
Operator is a bit too eager going on with the testing here, not checking all connection beforehand, resulting in the SSPA safety system trigging several times before it get going. (shame on me)
Here are a some pix & unabridged videos:

Been quite busy experimenting with this rf-switch the last couple of days.

There has arrived a lot on and off-list comments regarding rf-switches and I have not had the time to answer all, but thanks.

I am now up in what I call revision 4 switch.

What’s new:
Revised schematics for better RX/bypass-port isolation.
New 10 amps relays.
Have done a lot of λ/4 coax tuning.
TX loss is slightly better.
RX loss is slightly worse.
RX isolation is much better.

What needs to be done:
Switch works but the 75 ohm rg-179 stubs are getting way to hot when passing the Kw level.
Need to find something better.

Revised schematics for better RX/bypass-port isolation.

I have got some questions about the home brew rf-switch or relay in my previous post.
To clarify, I got this idea from Leif, sm5bsz web site.
He has done this with PIN-diodes. I don’t have suitable diodes on stock here so I substituted those with small relays. Problem is that lo-Z current at the relays are way to large, and I got to do something with that. Upgrading to larger relays would only make the Q higher and move the problem over to the coax subs I guess. I think. What is needed, is to lower the Q, maybe by adding a small resistor at the relays, say for example 0.1 ohm. (at the point of writing this, I must emphasize, I have not done the math yet.) But I have a feeling it my work. We will see………  🙂 

UPDATE: I have now done the math, and installing a series resistor at the lo-Z point will not lower the rf-current. It will only increase insertion loss. RF-current is about 4,2 amps, and my small signal relays are rated 2 amps @ 30VDC, Guess I got to find some larger ones.

Simplified schematic

Hi guys, I have an update regarding my mosfet troubles. To keep the story short……….:

Last weekend I got the replacement mosfet, I installed it, SUCCESS!!! According to its markings, it was a couple of years older than the other one, and it needed abt. 0.5 volt higher bias voltage, but this is fine once adjusted.

Then I started testing again, this time with a more mature swr protection system, this system tripped immediately. Hmmmmm. What could be wrong???

OK, fast forward, back to the time of breakdown event: It was a late weekend evening. The operator may have been a bit tired, eager to produce some results. There may have been a couple of beer cans in the way.  🙂 And the shack do not look good in daylight… this does not help at midnight, but it may appear better, visually.

I am now, pretty sure that the cause of the mosfet breakdown was a missing load, not spikes or over drive from the driver. Looking for the cause for the high swr situation mentions above, I found that the TX relay (narda 023 series) had a short due to internal welding!!!! Also, the coax connected to the transmitter port had a short. The RG-142 Teflon center insulator had developed a puncture, shorting it out!!!!! There have been some serious voltage on the loose here.

Well. I repaired the relay and exchanged the damaged coax. Up and running again, but not for long. A piece of advice; knowing about their internals, relays like the narda 023s, do not abuse them. They are high cost, wide band, low insertion loss, high power relays, but keep them below the rated power limit. I think these are rated to at abt. 1Kw @ 100 MHZ @ low vswrs conditions. Well, I tested it for key down, 2Kw at 3 minutes and it would not operate any more. Wye?? Because the internal plastic bits has melted and permanently deformed.

Looking for a better replacement I discovered that an electromechanically solution does not in practice exist at these power levels. Not what my wallet is going to accept any way.

Then I come to think of SM5BSZ Leifs page, about High Power PIN Diode Switch. Well, I do not have suitable PIN diodes, but I have many different relays. Let’s try that instead. …….And  it works. Only trouble is that my Q is to high. RF-current melt the solder and things broke down……again. But this can easily be rectified.

……..to be continued……….

……here are some pix.

Narda 023 series

 

New switch

 

still more new switch

 

Rear of new switch

Broken new switch 🙂 But this is going to be fixed.

 

 

 

Video above show the first run with the new switch. It broke down, but this time the mosfet protection works.

 

 

SHACK REPORT

SHACK REPORT

Well, last week was not a triumph! as I broke one of the mosfets in my 144mhz pa project.
I was hoping to receive the replacement before this weekend, but no such luck.

Did one qso by the moon last night @ 100 watts, but later I got some serious computer trouble and had to stop. Reason was me trying to do some upgrades at virtualized servers here, and it went bad, and things shut down. Been cleaning up all day and things are up and running again. Thankfully.

Also, one of my 4 bay NAS devices reported that it had a disk failure last night. So, now I have ordered new disks, larger ones as it was out of space anyway. Thanks to RAID no data was lost due to failure.

I am not motivated to turn to HF this evening, so Saturday night entertainment here is YouTube.

This is a drawing of the voltage & current sensing board. If you look further down on my site, this is the board on top of the rf-deck with red wires going through blue hall-effects elements. There is some more stuff on this board, and this is the VDD FET switches, but these are not in detail in the drawing.

Last night, during light burn-in tests, the amplifier suddenly dropped gain.
No alarms, no nothing, but one of the MOSFETS was drawing a lot less current compared to the other, it was also operating in class C. It turns out that for some reason the gate2 on the failing MOSFET has broken down. DAMN!!!!!!!!

Digging in to the RF-deck

 

Failed MOSFET

 

Gate2 to source breakdown. 70 ohm  dc-path between source and gate2 do not make any sense.

Have been working on my 144 MHz SSPA project since 04:00z this morning.
Now the time is 22:30z and I am tired. Continue tomorrow morning.
Here are some pictures of project status.

Starting point this moring

 

PT-100 Temperature sensor

 

Left/Front

 

Rear/Left

 

Rear/Left

 

Inside

 

More inside

 

73 All